Updated Firefox, now all CB buttons broken...

General discussion about Custom Buttons, including feature requests.

Updated Firefox, now all CB buttons broken...

Postby Drake1132 » Fri Feb 24, 2017 6:52 pm

Hi everyone,

I have done almost nothing with Custom Buttons in a long time. I got all of the buttons that I wanted for myself working and looking just the way I wanted them, and didn't need to make any changes (not since I had to use infocatcher's converter to convert from E4X to new format). So I just haven't seen the need to spend time with it past that point. But now I'm having problems.

Just this last week I updated Firefox from version 47 to the latest version (51.0.1) in 64-bit (I was using 32-bit for Firefox 47). This broke my custom buttons. All of them. And I can't go back and reinstall version 47 because I apparently no longer have the installation file for that version, and can't find it on the internet.
So I have a few questions I'd like to get answered please.

  1. Does CB work with Firefox 51.0.1?
  2. Does CB work with 64-bit versions of Firefox?
  3. If CB should be working in 64-bit Firefox 51.0.1, then is there anything that I need to do to all of my buttons to update them for the latest Firefox, or will I have to troubleshoot them all 1-by-1 ?
I'd appreciate some help with this.

Thanks,
Drake
Drake1132
 
Posts: 18
Joined: Thu Jan 24, 2013 9:39 pm

Re: Updated Firefox, now all CB buttons broken...

Postby Odyseus » Fri Feb 24, 2017 7:26 pm

Hello, Drake1132.

Your buttons aren't broken, is the version of Custom Buttons add-on that you have installed the one that it's broken.

The Custom Buttons add-on that is hosted on AMO (addons.mozilla.org) has been broken since Firefox 48. Use the one that is posted in the first post on this thread. Read and follow the instructions provided.
Odyseus
 
Posts: 434
Joined: Sun Mar 10, 2013 12:51 pm

Re: Updated Firefox, now all CB buttons broken...

Postby makondo » Fri Feb 24, 2017 7:34 pm

srazzano and i use Waterfox and his CB mod. Works fine.
The link to the srazzano mod file is 404 (dead), hopefully he'll update it, but here's my dropbox link to it.

EDIT:
Here's the latest.
makondo
 
Posts: 1653
Joined: Sun Dec 25, 2011 7:17 pm

Re: Updated Firefox, now all CB buttons broken...

Postby Drake1132 » Fri Feb 24, 2017 11:18 pm

Thank you both for your very speedy and informative posts. I appreciate it.

The post that Odyseus linked to includes a *zip file download, which does work (once you follow the directions to allow unsigned add-ons). So that was great. But my navigation buttons didn't work 100% with that add-on. The tab history dropdown menus didn't work, but the actual back and forward functionality, as well as the functionality of my other buttons did work fine.

So then I downloaded and tried CB3 from the post that Makondo linked and tried that one. CB3 seems to work perfectly, and all of my buttons are working again.

Again, thank you both. You've been very helpful and I appreciate it.

Later,
Drake
Drake1132
 
Posts: 18
Joined: Thu Jan 24, 2013 9:39 pm

Re: Updated Firefox, now all CB buttons broken...

Postby makondo » Sat Feb 25, 2017 4:14 am

Thanks go to srazzano, of course, but you're welcome, glad it works for you. Good Luck!
makondo
 
Posts: 1653
Joined: Sun Dec 25, 2011 7:17 pm


Return to General Discussion

cron