Insert Smiley

Re: Insert Smiley

Postby makondo » Wed Feb 22, 2017 5:14 pm

I have ~190? images. By 'decimal' i mean by 10,20,30 .... as you proposed above.
makondo
 
Posts: 1636
Joined: Sun Dec 25, 2011 7:17 pm

Re: Insert Smiley

Postby srazzano » Wed Feb 22, 2017 5:30 pm

Insert Smiley @makondo

Minor code and css adjustments. Formated id's as 1.00, 2.00, 3.00, etc... Thought you might want to group similar gif's using #1.00, #1.10, #1.20 and another similar group as #2.00, #2.10 and so on. If not, just set the id's to 1, 10, etc...
srazzano
 
Posts: 1508
Joined: Sat Mar 31, 2012 6:42 pm
Location: Las Vegas, Nevada

Re: Insert Smiley

Postby makondo » Wed Feb 22, 2017 6:04 pm

OK, i edited all numbers like so:
<image item="4.00" name="Phew!..." src="http://i.imgur.com/5d41T.png"/>\

but the tooltip doesn't show ID #. It shows (Item )

1.png
1.png (72.11 KiB) Viewed 1207 times
makondo
 
Posts: 1636
Joined: Sun Dec 25, 2011 7:17 pm

Re: Insert Smiley

Postby srazzano » Wed Feb 22, 2017 6:15 pm

Insert Smiley @makondo

ID is before name. Let me know if you want them reversed.
srazzano
 
Posts: 1508
Joined: Sat Mar 31, 2012 6:42 pm
Location: Las Vegas, Nevada

Re: Insert Smiley

Postby makondo » Wed Feb 22, 2017 7:11 pm

OK, this seems to work, thanks a lot! I don't have to fiddle with those numbers anymore! (although i doubt i'll be adding many more images anyway now ... Image ... still great to know!).

Image
makondo
 
Posts: 1636
Joined: Sun Dec 25, 2011 7:17 pm

Re: Insert Smiley

Postby makondo » Thu Feb 23, 2017 2:09 am

srazzano,
check your PM.
makondo
 
Posts: 1636
Joined: Sun Dec 25, 2011 7:17 pm

Re: Insert Smiley

Postby makondo » Sun Nov 19, 2017 5:22 pm

Here we go again, pasted my smileys > button broke!

EDIT: needed 2 restarts to get it running.
But the css2 did change (answers my question). So, have to remember to savE all css codes before updating!

Thanks for the update!
makondo
 
Posts: 1636
Joined: Sun Dec 25, 2011 7:17 pm

Re: Insert Smiley

Postby srazzano » Sun Nov 19, 2017 7:57 pm

The restarts needed have to do with Watefox itself. Even when I edit my add-ons, I have to repack into an xpi and reinstall for them to take effect. It's like the cache doesn't clear with changes. I hope that gets corrected in v56.
srazzano
 
Posts: 1508
Joined: Sat Mar 31, 2012 6:42 pm
Location: Las Vegas, Nevada

Re: Insert Smiley

Postby makondo » Sun Nov 19, 2017 9:07 pm

I just found the weirdest problem: was typing a PM in the TMP forum and was going to add a smiley BUT! when i click on one, it opens Options dialog but doesn't paste smiley! Weird or what?
makondo
 
Posts: 1636
Joined: Sun Dec 25, 2011 7:17 pm

Re: Insert Smiley

Postby makondo » Sun Nov 19, 2017 9:16 pm

srazzano,
may i ask you for a favor, please? Could you please go the the new forum in TMP hereand try posting a new thread (just name it Test or something, i will delete it anyway), i need to check if i set permissions correctly there. TIA!
makondo
 
Posts: 1636
Joined: Sun Dec 25, 2011 7:17 pm

PreviousNext

Return to Buttons made by forum users