{FIXED} Favicon Plus 4.0.1 Does Not Work in WaterFox v54.0.1

User support for problems with custom buttons

Re: Favicon Plus 4.0.1 Does Not Work in WaterFox v54.0.1

Postby BobbyW » Sun Aug 13, 2017 1:04 am

@Sonny

I installed your button. Thanks for your time & effort.

The button Icon animates when pressed & released.

Nothing happens on Middle-Click or Left-Click. Image

Right-Click gets me the usual button menu.

What, if anything, do I need to do to activate it?

Being I am not a coder I refrained from "playing" with anything.

PS.......Just for S&G I installed your button on Pale Moon v26.5....works fine on PM (just like the old button), but not on WF v54.0.1.
Last edited by BobbyW on Sun Aug 13, 2017 1:22 am, edited 1 time in total.
BobbyW
 
Posts: 244
Joined: Sat Dec 31, 2011 6:03 am

Re: Favicon Plus 4.0.1 Does Not Work in WaterFox v54.0.1

Postby srazzano » Sun Aug 13, 2017 1:18 am

Have you tried a restart after install? Is the button grayed out? Should be no animation on toolbarbutton. Do you see a tooltip on button hover? Are you using Waterfox 54.0.1 browser? Nothing assigned to middle-click. Left-click toolbar button drops the menu with 5 menuitems you desired.
(1) Copies tab icon url to clipboard
(2) Opens filepicker with default string of the tab icon image to be saved to selected folder
(3) Converts selected file from filepicker to base64 data on clipboard
(4) Prompts for an base64 data entry to be saved to folded as image file via filepicker
(5) Prompts for an base64 data entry to be viewed in viewer

Image
srazzano
 
Posts: 1472
Joined: Sat Mar 31, 2012 6:42 pm
Location: Las Vegas, Nevada

{FIXED} Favicon Plus 4.0.1 Does Not Work in WaterFox v54.0.1

Postby BobbyW » Sun Aug 13, 2017 1:29 am

srazzano wrote:Have you tried a restart after install? Is the button grayed out? Should be no animation on toolbarbutton. Do you see a tooltip on button hover? Are you using Waterfox 54.0.1 browser? Nothing assigned to middle-click. Left-click toolbar button drops the menu with 5 menuitems you desired.
(1) Copies tab icon url to clipboard
(2) Opens filepicker with default string of the tab icon image to be saved to selected folder
(3) Converts selected file from filepicker to base64 data on clipboard
(4) Prompts for an base64 data entry to be saved to folded as image file via filepicker
(5) Prompts for an base64 data entry to be viewed in viewer

Image


Image...Duhhh....I feel like a real dope....Image

Works on restart!! Image

This is great!!! Image

I'll let you know if I have any problems, but I'm sure everything will work just fine.

Update: I've fully tested the Completely New & Improved Favicon Plus Button, & it worked flawlessly!

Thanks ever so much again!! Image Image
BobbyW
 
Posts: 244
Joined: Sat Dec 31, 2011 6:03 am

Re: {FIXED} Favicon Plus 4.0.1 Does Not Work in WaterFox v54

Postby srazzano » Wed Aug 16, 2017 4:14 am

@BobbyW,

Image https://sonco.synthasite.com/base64-encoder.php

If interested, I modified an add-on I created some time ago that will replace the Favicon Plus button, with more detail. It will also fetch src images from web pages, by right-clicking on target image and select Base64⇒Encoder menuitem from contentAreaContextMenu.

Base64⇒Encoder Dialog
Image
Base64⇒Encoder Alert Setting
Image
srazzano
 
Posts: 1472
Joined: Sat Mar 31, 2012 6:42 pm
Location: Las Vegas, Nevada

Re: {FIXED} Favicon Plus 4.0.1 Does Not Work in WaterFox v54

Postby BobbyW » Fri Aug 25, 2017 9:06 am

Thanks Sonny for this New edition of Base64 Encoder.

Sorry it took me so long to reply, my recuperation from a scheduled surgery had me unable to respond until now. I'm about 75% today, & will give it a real go soon as I can think more clearly.

Thanks again.......I really do appreciate your work & time very much. Image
BobbyW
 
Posts: 244
Joined: Sat Dec 31, 2011 6:03 am

Re: {FIXED} Favicon Plus 4.0.1 Does Not Work in WaterFox v54

Postby makondo » Fri Aug 25, 2017 3:16 pm

Get well soon, Bobby!
makondo
 
Posts: 1585
Joined: Sun Dec 25, 2011 7:17 pm

Re: {FIXED} Favicon Plus 4.0.1 Does Not Work in WaterFox v54

Postby BobbyW » Tue Sep 05, 2017 12:38 am

makondo wrote:Get well soon, Bobby!


Thanks Mak....Progress is slow, but the future looks very good. Image




srazzano wrote:@BobbyW,

If interested, I modified an add-on I created some time ago that will replace the Favicon Plus button, with more detail. It will also fetch src images from web pages, by right-clicking on target image and select Base64⇒Encoder menuitem from contentAreaContextMenu.



Thanks Sonny......I vaguely remember us working together on something similar some years ago (you probably did all the work, & all I did was the testing under fire).....I think it was a base64 Encoder extension????

Well, this button is very nice......I can see where I could use it, especially the menuitem portion. I find getting my head around that alert feature....what exactly does it do, how is it used. I will need to write a "How To" (kept in my ever expanding repository of how to's ) on this buttons use & features, so down the road I will have a refreshing reference, rather than relying on my extremely fleeting memory. I used to rely on the HELP tab, but nobody seems to populate that with help now a days, it seems to have become a place for more coding.......where it should be renamed from HELP to say DATA....or another section added, leaving HELP for help.

Any Ideas on a step by step for this fine button would be a great help for me & others like me too who might happen to pass into this thread.....

Thanks.......Image
BobbyW
 
Posts: 244
Joined: Sat Dec 31, 2011 6:03 am

Re: {FIXED} Favicon Plus 4.0.1 Does Not Work in WaterFox v54

Postby srazzano » Tue Sep 05, 2017 1:11 am

NM
srazzano
 
Posts: 1472
Joined: Sat Mar 31, 2012 6:42 pm
Location: Las Vegas, Nevada

Previous

Return to Buttons